Tezos (XTZ) under maintenance
Incident Report for Bitpanda
Resolved
We are happy to announce that Tezos (XTZ) transactions are working again. Thank you very much for your patience.
Posted Jul 27, 2021 - 15:04 CEST
Investigating
Unfortunately, no Tezos transactions are possible for now due to maintenance. We are working hard to make Tezos fully operational again soon.
Posted Jul 02, 2021 - 17:05 CEST
This incident affected: Digital Assets (Tezos (XTZ)).