Bitpanda Pro maintenance
Incident Report for Bitpanda
Resolved
Maintenance for Bitpanda Pro is concluded. Thank you for your patience.
Posted Sep 06, 2021 - 09:12 CEST
Investigating
Due to scheduled maintenance for Bitpanda Pro on Monday, the 6th of September 2021 from 07:00 CET, logins and trading on Bitpanda Pro will be affected for about 2 hours.

We apologise for any inconvenience this may cause.
Posted Sep 04, 2021 - 13:11 CEST