Delay in Updating Account Balances

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 13:23 CEST

Investigating

We are currently experiencing a display issue affecting portfolio balances on both our web and mobile applications. Please note that all transactions are being processed correctly on our backend systems, and your funds are safe.

Our engineering teams are working to resolve the situation as quickly as possible. We appreciate your patience while we work to restore full service.
Posted Apr 08, 2026 - 10:34 CEST