LUNA airdrop details
Incident Report for Bitpanda
Resolved
We are continuing to work on clarifying all open questions and will notify you you about all further developments as soon as possible.
Posted Jun 22, 2022 - 12:55 CEST
Monitoring
After a successful migration, we are happy to update you with some details on the airdrop. Please find our updated article on blog.bitpanda.com. Thank you for your patience.
Posted Jun 09, 2022 - 17:57 CEST
This incident affected: Trade Only Assets (Terra 2.0 (LUNA), Terra Classic (LUNC)).