Deutsche Bank deposits are temporarily delayed

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 16:03 CEST

Investigating

Deutsche Bank deposits are temporarily delayed due to an issue on bank side. We appreciate your patience and recommend checking this page for updates.
Posted Jul 22, 2025 - 20:18 CEST