Stock price update issue (20% of stocks affected)
Incident Report for Bitpanda
Resolved
The issue is resolved. All our stocks have up-to-date prices
Posted Jan 09, 2023 - 09:09 CET
Identified
Due to an issue with one of our providers, we don't have up-to-date stock prices for about 20% of our stock portfolio. We expect the issue to be resolved by Monday morning
Posted Jan 08, 2023 - 19:32 CET