Transaction history export issues
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 09:39 CET
Update
A fix was released resolving the issue for most users. The upcoming fix is expected to resolve the issue for everyone.
Posted Jan 05, 2024 - 12:44 CET
Identified
Our transaction history export functionality is experiencing issues. Please contact Customer Care if you are unable to download your history export after multiple attempts.

Our developers are working on resolving the issue as soon as possible.
Posted Dec 07, 2023 - 15:16 CET