Solana withdrawals currently unavailable
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Mar 10, 2024 - 20:16 CET
Investigating
We are currently experiencing an issue with Solana (SOL) withdrawals . Our team is actively working on resolving this issue. We appreciate your patience and will provide updates as soon as possible. Thank you for your understanding.
Posted Mar 10, 2024 - 19:43 CET