Bitpanda card activation issue
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 17:17 CEST
Update
We are continuing to investigate this issue.
Posted Jun 18, 2021 - 17:13 CEST
Investigating
Resolved - We are happy to announce that Bitpanda card activation is fully operational again.

At the moment, Bitpanda cards cannot be activated.

If you have already ordered a card, please do not reorder a new card. We are working on it to fix this issue. As soon as the matter is resolved, you can activate your current Bitpanda card.
Posted Jun 18, 2021 - 10:57 CEST
This incident affected: Bitpanda Card (Card Activation).