Bitpanda Card Dashboard Fix
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 19:31 CET
Identified
There can be minor issues occurring in regards to the dashboard of Bitpanda Card. We will soon deploy a fix. Thank you for your patience.
Posted Jan 12, 2022 - 17:24 CET
This incident affected: Bitpanda Card (Bitpanda Card Dashboard).