Buying and selling BCI is currently unavailable
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted May 14, 2022 - 10:06 CEST
Investigating
BCI trading is currently unavailable. We are working on a solution and we will keep you updated.
Thank you for your patience.
Posted May 13, 2022 - 11:32 CEST
This incident affected: Trade Only Assets (Bitpanda Crypto Index 5, Bitpanda Crypto Index 10, Bitpanda Crypto Index 25).