Savings Plans delayed
Incident Report for Bitpanda
Resolved
The issue has been found and successfully resolved. Thank you very much for your patience.
Posted Nov 18, 2021 - 09:27 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 09, 2021 - 19:34 CET
Identified
Currently, certain savings plans might be delayed. We are looking into it to fix the issue as soon as possible.

Thank you very much for your understanding and patience.
Posted Nov 02, 2021 - 11:37 CET
Investigating
Currently, our savings plans show slight delays. We are looking into it to fix the issue as soon as possible.
Posted Oct 05, 2021 - 11:18 CEST