Deutsche Bank withdrawals are temporarily unavailable

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 18:36 CEST

Investigating

Deutsche Bank withdrawals are temporarily unavailable due to a technical issue. We understand this may cause inconvenience and are working urgently to fix this issue.
Thank you for your understanding!
Posted Jun 12, 2025 - 16:37 CEST