Savings Plans Delays
Incident Report for Bitpanda
Resolved
The fix has been implemented, so the delayed savings plans are now executed. Thank you for your patience once again.
Posted Apr 19, 2022 - 17:39 CEST
Investigating
We are aware that some savings plans may be currently executed with delays. However, a fix will be deployed shortly. Please subscribe to this incident to be informed about every update automatically. Sorry for the inconvenience and thank you for your patience.
Posted Apr 19, 2022 - 13:36 CEST