Crypto and Fiat deposit processing delays

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Oct 12, 2025 - 01:42 CEST

Identified

Due to a an extended maintenance on one of our partners' side, we're processing part of deposit and withdrawal transactions at a slower pace.
We apologise for the inconvenience the incident might cause.
Posted Oct 11, 2025 - 20:23 CEST