Mpay24 Deposits Processing Issues

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Jun 20, 2024 - 07:20 CEST

Investigating

We are currently experiencing an issue with Mpay24 deposits not being processed. Our team is actively working on resolving this issue. We apologize for the inconvenience and appreciate your patience.
Posted Jun 20, 2024 - 05:57 CEST
This incident affected: Bitpanda (Payment methods).