IOTA (MIOTA) withdrawal issue
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 14:20 CEST
Investigating
Withdrawals and deposits for IOTA are currently disabled. We will provide further information as soon as there are updates. Thank you for your patience.
Posted Oct 02, 2021 - 16:20 CEST
This incident affected: Digital Assets (IOTA (MIOTA)).