Paypal deposits unavailable due to issues on PayPal side

Incident Report for Bitpanda

Resolved

The issue has been resolved and deposits through Paypal are available again.
Posted Oct 16, 2025 - 19:32 CEST

Investigating

We are currently experiencing issues with Paypal deposits due to an ongoing technical issue on Paypal's side. We’re actively working with our partner to restore normal operations and will provide updates as soon as we have more information.
Posted Oct 16, 2025 - 18:33 CEST
This incident affected: Bitpanda (Payment methods).