Scheduled maintenance

Scheduled for Nov 25, 23:00 CET  -  Nov 26, 00:00 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 19, 2025 - 11:41 CET

Scheduled

We will be undergoing scheduled maintenance at this time. Core functionalities might be degraded briefly during the maintenance.
Posted Nov 19, 2025 - 11:39 CET
This scheduled maintenance affects: Bitpanda (Bitpanda Login Service, Bitpanda Trading).