Crypto Wallet Balances
Incident Report for Bitpanda
Resolved
The incidence regarding the crypto wallet balances has been resolved. It might take another short moment for a few additional users to see the updated balances. Thanks for your patience.
Posted Jun 24, 2021 - 00:19 CEST
Investigating
Unfortunately, we are facing some technical issues with the display of the crypto wallets. Our developers are already aware of the problem and are currently working on fixing it. Thank you for your patience.
Posted Jun 19, 2021 - 10:44 CEST
This incident affected: Bitpanda (Crypto Wallet Balances).