ATOM trade only
Incident Report for Bitpanda
Resolved
We are happy to announce that ATOM transaction issues have been successfully resolved. Thank you very much for your patience.
Posted Jun 14, 2021 - 16:38 CEST
Investigating
Unfortunately, we are monitoring some technical difficulties in ATOM transactions. We are carrying out an investigation and will enable them again as soon as possible. Thank you for your patience.
Posted Jun 10, 2021 - 10:52 CEST
This incident affected: Digital Assets (Cosmos (ATOM)).