Bitpanda: maintenance works
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 09:25 CEST
Investigating
We are carrying out some minor maintenance works today (Thursday, 02.09.2021) to improve the stability of our performance for digital assets. Please be aware that you may experience minor performance issues.
Posted Sep 02, 2021 - 00:01 CEST