Mpay Deposit options is currently unavailable due to possible 3rd party issues

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Nov 21, 2024 - 13:09 CET

Investigating

We are currently investigating this issue.
Posted Nov 20, 2024 - 20:31 CET
This incident affected: Bitpanda (Payment methods).