We are currently experiencing problems with logging in on multiple platforms. We advise you to avoid logging off at the moment.

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 09:08 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 09:00 CET

Investigating

We are currently experiencing problems with logging in on multiple platforms. Our team is actively investigating the issue and working to restore normal functionality as quickly as possible. We apologize for any inconvenience this may cause and will provide updates as soon as we have more information. Thank you for your patience.
Posted Mar 05, 2025 - 08:35 CET
This incident affected: Bitpanda (Bitpanda Login Service).