Trading for Terra (LUNA) has been stopped
Incident Report for Bitpanda
Resolved
Trading for Terra (LUNA) is available again.
Thank you for your patience.
Posted May 14, 2022 - 18:05 CEST
Identified
Due to a global issue with Terra (LUNA), trading has been stopped.
Posted May 13, 2022 - 05:45 CEST
This incident affected: Trade Only Assets (Terra (LUNA)).