Nvidia Stock Split
Incident Report for Bitpanda
Resolved
We are happy to announce that the NVDA stock split is over. NVDA ETF is now fully operational again
Posted Jul 23, 2021 - 00:08 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 23, 2021 - 00:06 CEST
Update
The buying option is now enabled again and we are working on the next steps to also enable the selling option.

Thank you for your patience.
Posted Jul 20, 2021 - 10:58 CEST
Monitoring
Due to some minor issues, the enabling of the buying option again on the 20th of July at 8:30 CEST will be delayed.

We are working hard on fixing these minor issues and will enable all trading functions as soon as possible again.

We are sorry for the inconvenience and thank you for your patience.
Posted Jul 20, 2021 - 09:42 CEST
Identified
We will soon re-enable the buy option for NVDA. Thank you for your patience.
Posted Jul 20, 2021 - 09:34 CEST
Update
Please be aware that, because of the upcoming NVDA/ Nvidia-Stock-Split, trading will be disabled at 19:00 CEST, for a short period of time.

We plan to enable the buying option again on the 20th of July at 8:30 CEST, with the selling option soon following.

Thank you for your understanding.
Posted Jul 19, 2021 - 15:00 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 15, 2021 - 13:33 CEST
Monitoring
We are happy to announce that there will be an NVDA/ Nvidia-Stock-Split on the 19th of July.

Please be aware that trading will not be enabled from 19.07.2021, 19:00 CEST, for a short period of time. We will enable it again though as soon as possible
Posted Jul 15, 2021 - 13:27 CEST
This incident affected: Digital Assets (NVDA ETF).