Zcash maintenance
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 21:10 CEST
Investigating
The deposit and withdrawal option for Zcash is currently disabled. We are working hard to make it fully operational again as soon as possible.
Posted Jun 18, 2021 - 20:16 CEST