We are currently experiencing issues with the availability of our platforms.

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Mar 02, 2025 - 19:29 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2025 - 18:17 CET

Investigating

We are currently investigating this issue.
Posted Mar 02, 2025 - 18:16 CET
This incident affected: Bitpanda (Bitpanda Website (https://www.bitpanda.com), Bitpanda Android app, Bitpanda iOS app).