We have identified an issue causing Visa deposits to fail when processed through Worldpay.

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 14:27 CET

Investigating

We have identified an issue causing Visa deposits to fail when processed through Worldpay.
Our team is currently investigating the root cause and working on a permanent fix. Further updates will be provided as soon as more information becomes available. In the meantime, please use the alternative deposit options.

We apologize for any inconvenience and appreciate your patience.
Posted Mar 14, 2025 - 01:30 CET
This incident affected: Bitpanda (Payment methods).