Delayed fiat deposits using Worldpay

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Oct 06, 2024 - 13:21 CEST

Identified

Fiat deposits via Worldpay are delayed due to an issue on the provider side.
Posted Oct 06, 2024 - 11:42 CEST
This incident affected: Bitpanda (Payment methods).