Paypal deposits are currently unavailable due to 3rd party provider issues , please use diffirent deposit providers
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 13:19 CEST
Investigating
We are currently investigating this issue.
Posted Oct 16, 2024 - 21:34 CEST