Bank holiday in Liechtenstein
Incident Report for Bitpanda
Resolved
SEPA transactions in CHF are processed normally again.
Posted Sep 10, 2021 - 14:13 CEST
Identified
Due to a bank holiday, Bank Frick in Liechtenstein will be closed on Wednesday, 8th September 2021.

On this day, no SEPA transaction in Swiss Franc (CHF) will be processed. We will receive deposits and process withdrawals in CHF again on the day after the bank holiday, 9th September 2021.
Posted Sep 06, 2021 - 09:45 CEST