Trading via Fusion has been temporarily disabled due to a technical issues

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 15:15 CEST

Investigating

Trading via Fusion has been temporarily disabled due to technical issues. We are working on restoring Fusion as soon as possible. We apologize for the inconvenience this might cause.
Posted Jun 02, 2026 - 13:15 CEST
This incident affected: Fusion (Fusion).