Staking reward payout delayed
Incident Report for Bitpanda
Resolved
All Staking rewards are paid out.
Posted Feb 01, 2023 - 09:58 CET
Investigating
We are experiencing delays with the payout of the staking rewards. We are looking into this with highest priority.
Posted Feb 01, 2023 - 09:09 CET