Customer care ticketing system having issues

Incident Report for Bitpanda

Resolved

Reported issue has been resolved.
Posted Feb 16, 2023 - 08:51 CET

Update

We are continuing to investigate this issue
Posted Feb 15, 2023 - 22:34 CET

Investigating

We are expriencing issues with our internal customer care systems which may result in delayed response from our teams.
Our other services are unaffected.

Thank you for your patience while we try to resolve the issue as soon as possible.
Posted Feb 15, 2023 - 22:10 CET