Cryptocurrency trading down due to technical issue

Incident Report for Bitpanda

Resolved

The incident has been resolved.
Posted Apr 17, 2023 - 11:46 CEST

Update

We are continuing to work on a fix for this issue.
Posted Apr 17, 2023 - 11:24 CEST

Identified

Due to technical issues trading is not possible on our platform. We're working on resolving the issue as soon as possible. We apologize for the inconvenience.
Posted Apr 17, 2023 - 11:21 CEST