EPS/Giropay maintenance
Incident Report for Bitpanda
Resolved
We accomplished the maintenance, so you can use EPS/Giropay are again. We appreciate your patience.
Posted Oct 13, 2021 - 09:45 CEST
Identified
Unfortunately, EPS/Giropay are currently not available due to maintenance. We are working hard to re-enable them as soon as possible. Thank you very much for your patience.
Posted Oct 08, 2021 - 18:24 CEST
This incident affected: Payment Methods (EPS, Giropay).