PayPal deposits are currently unavailable

Incident Report for Bitpanda

Resolved

The issue has been resolved , and Paypal deposits are back online
Posted Apr 12, 2024 - 23:10 CEST

Investigating

We are currently experiencing an issue with PayPal deposits, recent deposits with that method are also delayed. Our team is actively working on resolving this issue. We appreciate your patience and will provide updates as soon as possible. Thank you for your understanding.
Posted Apr 12, 2024 - 21:25 CEST