Issues with contact form
Incident Report for Bitpanda
Resolved
This incident has been resolved. Thank you.
Posted Sep 03, 2021 - 00:39 CEST
Identified
We identified an issue with our contact form and working on a solution to fix some design issues. It's expected to change back to normal within the next few minutes. Please retry it soon or click through the form as you can. Ongoing cases are not affected and will be processed as usual. Thank you.
Posted Sep 03, 2021 - 00:20 CEST
This incident affected: Other Components (Customer Support).