Giropay Maintenance
Incident Report for Bitpanda
Resolved
The maintenance works are now successfully finished, so Giropay can be now used again as usually. Thanks you very much for your patience.
Posted Oct 01, 2021 - 22:23 CEST
Identified
Giropay is currently being updated and will be available again as soon as the update has been processed
Posted Oct 01, 2021 - 10:59 CEST
This incident affected: Payment Methods (Giropay).