Bitpanda Savings Plan performance issues
Incident Report for Bitpanda
Resolved
The issue regarding delays in saving plans is now resolved. Your saving plans are executed on time again.
Posted Jul 08, 2021 - 13:31 CEST
Investigating
We are currently experiencing performance issues with the Bitpanda Savings Plan. In some cases, a delay of two days could be expected. We apologise for any inconvenience caused by this. We highly value your patience.
Posted Jul 06, 2021 - 14:55 CEST
This incident affected: Payment Methods (Bitpanda Savings).