Portfolio and wallet balances display
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 15:53 CEST
Investigating
Some users are affected by portfolio and wallet balances not updating after successfully concluded trades. This is a display issue and does not affect the actual balance. We are currently working to fix it.
Posted Sep 03, 2021 - 16:36 CEST