We are currently experiencing issues while requesting a new Bitpanda Card due to inability to confirm Proof of Address

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 17:10 CET

Update

Issue has been fixed, normal function is restored.
Posted Mar 15, 2025 - 17:09 CET

Investigating

We are currently investigating this issue.
Posted Mar 15, 2025 - 13:02 CET
This incident affected: Bitpanda (Bitpanda Card).