Deposits for some currencies (PLN, CZK, DKK, NOK, HUF, SEK) for PaySafe Mastercard and Visa are currently unavailable.
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 15:29 CET
Identified
The issue has been identified on the vendor side and is currently being address.
Posted Nov 01, 2024 - 14:34 CET
This incident affected: Bitpanda (Payment methods).