Payment methods

Incident Report for Bitpanda

Resolved

The issue had been solved by our card payment provider.
Posted Apr 29, 2026 - 22:22 CEST

Investigating

One of our card payment providers is experiencing a technical issue affecting transaction authorizations, so deposits could be delayed. We apologize for the inconvenience and will provide an update as soon as the issue is resolved.
Posted Apr 29, 2026 - 21:10 CEST