Deutsche Bank deposits and withdrawals are temporarily unavailable

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 15:23 CEST

Investigating

We're currently experiencing a temporary issue affecting all deposit and withdrawal services with Deutsche Bank. Our technical teams are actively investigating and working to resolve this as quickly as possible.
We appreciate your patience and recommend checking this page for updates.
Posted Jul 04, 2025 - 13:30 CEST