Trading of Bitpanda Stocks & ETFs halted
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 11:31 CET
Investigating
Buying and selling of Bitpanda Stocks & ETFs is currently partially not possible. We are working on it to fix the issue and will keep you up to date.

We are sorry for any inconvenience caused.
Posted Jan 05, 2022 - 10:57 CET