GBP deposits and withdrawals stuck

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted May 30, 2024 - 11:25 CEST

Investigating

We are facing an issue with GBP deposits and withdrawals. Our team is working hard on resolving the issue with our partners. We apologize for the inconvenience this might cause. Pending deposits and withdrawals will be processed once the technical issue is resolved
Posted May 30, 2024 - 09:58 CEST
This incident affected: Bitpanda (Payment methods, Payout methods).