CHF withdrawals
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Nov 20, 2021 - 11:43 CET
Investigating
There might be some delays with CHF withdrawals initiated from 12. Nov onwards. We are working on the fastest solution. Thank you for your patience and understanding.
Posted Nov 15, 2021 - 20:27 CET