Crypto Deposit and Withdrawal Processing Issue
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jan 20, 2024 - 21:53 CET
Update
We are continuing to investigate this issue.
Posted Jan 20, 2024 - 19:14 CET
Investigating
We are currently experiencing an issue with crypto deposits not being processed.
Our team is actively investigating and updates will be provided shortly.
We apologize for the inconvenience and appreciate your patience.
Posted Jan 20, 2024 - 18:43 CET